# package lock.json

3개의 포스트
post-thumbnail

[경고] The package-lock.json file was created with an old version of npm,

문제 git clone으로 프로젝트를 다운받고 npm i 하였는데, 다음과 같은 현상이 발생함. npm run start 하기에는 지장 없음. package-lock.json 파일이 낮은 버전의 npm으로 만들어졌다는 경고가 뜸. package-lock.json에서 l

2022년 3월 22일
·
0개의 댓글

package.json과 package-lock.json 파일이 나눠져 있는 이유

npm install을 사용하는 경우, package.json / package-lock.json파일 기준으로 패키지를 설치하는데 왜 둘로 나누어져 있나?package.json은 version range로만 표시하여, 패키지가 마이너한 업데이트 하더라도 작동에 문제없도

2021년 8월 18일
·
0개의 댓글
post-thumbnail

TIL 7월 21일 - mocha 기본 사용법, package-lock.json이란?, package.json 만들기

mocha 기본 사용법 getting started in my editor: back in terminal: set up a test script in package.json: Then run tests with: 아니면 json파일 수정은 생략하고 아래와 같이 실행해주면 된다. 참고 https://mochajs.org/#installation...

2019년 7월 21일
·
0개의 댓글