# err

18개의 포스트

[ERR] Assignment to property of function parameter '??’

todo 웹 페이지를 만들면서 문자열 배열이였던 데이터를 완료여부와 컨텐츠를 가진 객체 배열로 변경했다.완료된 todo의 boolean 값을 아래와 같이 바꾸면서 에러가 발생했다.ESLint 오류였으며, https://eslint.org/docs/rules/n

2022년 5월 31일
·
0개의 댓글

[ERR] Type 'void' is not assignable to type 'string[]' 외 다수

거...많기도 하다...넘겨준 상태갱신 함수를 실행하는 단계에서 에러가 발생했다.함수의 매개변수와 함수의 타입의 선언이 제대로 이루어지지 않아서 생기는 문제였다.이전의 갱신함수 전달에서 생겼던 문제는 타입을 작성하지 않아서였고, 이번에 생긴 에러는 타입을 잘못 설정해서

2022년 5월 26일
·
0개의 댓글

[ERR] Type 'ChangeEvent<HTMLInputElement>' is not assignable to type 'SetStateAction<string>'.

input 이 변경될 때 해당 내용을 상태로 저장하고자 했을 때 생긴 에러.에러 메시지 상에서 무언가 변경되는 이벤트를 뜻하는 타입에 상태를 변경시키는 함수를 뜻하는 타입을 할당 할 수 없다는 내용을 표시했다.완벽하게 이해가 되진 않지만, 에러 메시지로 보아 서로 다른

2022년 5월 26일
·
0개의 댓글

[ERR] TS2322: Type '??' is not assignable to type 'IntrinsicAttributes & IProps'.

하위 컴포넌트로 상태갱신 함수를 전달하던 중 타입에러가 발생했다.이는 하위 컴포넌트에서 전달받으려는 props의 타입을 지정해주지 않아서 생기는 오류였다.먼저, 어떤 타입이 전달될지 모르므로 any와 unknown 타입을 선택 할 수 있었는데, 둘중 unknown 이

2022년 5월 26일
·
0개의 댓글

[ERR] 'React' must be in scope when using JSX react

타입스크립트로 컴포넌트를 생성하고 eslint 를 설치해 적용하자 표시된 에러.컴포넌트 생성시 react 를 import 하지 않아서 생성된 lint 에러.최상단에 import React from ‘react’; 를 작성하니 해결되었다.import react from

2022년 5월 12일
·
0개의 댓글

[ERR] Error: "prettier/react" has been merged into "prettier”...

ERR WHEN TS, eslint, prettier 를 사용하기 위한 초기 설정중에 발생한 에러로, 기존 블로그들을 참고하는 중에 "plugin:@typescript-eslint/recommended" 를 extends 에 추가하는 과정이 있었다. .eslintrc.json 에 extends 를 설정 후에 lint 를 실행하자 에러가 발생하였고, 정...

2022년 5월 12일
·
0개의 댓글
post-thumbnail

ERR 오류해결 @eslint/eslintrc@1.2.2: The engine "node" is incompatible with this module. Expected version "^12.22.0 || ^14.17.0 || >=16.0.0". Got "14.15.5"

전에 없던 오류인데 갑자기 떠서 검색해보니 구선생님도 모른다는 소식에 좌절하고 있었다 ㅠㅠ심지어 설치파일에는 next 에 당연히 들어있어야하는 pages폴더도 없고.. 아무것도 존재하지 않은 상태..!분명 버전문제같아 찾아봤는데 도무지 모르겠어서 이것저것 검색하던 중

2022년 4월 27일
·
0개의 댓글

BadRequestKeyError: 400 Bad Request

BadRequestKeyError: 400 Bad Request

2022년 4월 26일
·
0개의 댓글

4월 23일 (금) 자바스크립트에서 타입스크립트 변환 중 에러

즉, 브라우저는 형식 스크립트를 이해하지 못하고 단순히 index.ts를 가리킬 수는 없다 먼저 JavaScript로 컴파일해야 한다고 한다 tsconfig.json에서 먼가 설정을 해줘야 하는건가 ..

2022년 4월 22일
·
0개의 댓글
post-thumbnail

git Err : Updates were rejected because the tip of your current branch is behind 오류해결하기

깃 초기세팅에 맞게 해봤지만 ㅠㅠ 도무지 뭐가 문젠지 몰라서 서칭해보니 데이터 유실문제때문에 git push --set-upstream origin main 가 먹히지 않는거라고 한다 git push -u origin +main 를 해주면된다고 한다.오류 해결 끝!

2022년 4월 15일
·
0개의 댓글
post-thumbnail

Vue : npm run serve 오류 vue-cli-service: command not found

git clone을 받고npm run serve로 실행을 시켜주었는데이런 에러들이 뜨는 경우가 있다 이경우는npm cinpm run servenpm ci 로 기존에 깔려있거나 업데이트 되어있는 패키지를 재실행 해주면 정상적으로 실행할 수 있다!

2022년 4월 12일
·
0개의 댓글

[Android Studio] No toolchains found in the NDK toolchains folder for ABI with prefix: arm-linux-androideabi

err message : No toolchains found in the NDK toolchains folder for ABI with prefix: arm-linux-androideabi

2022년 3월 23일
·
0개의 댓글

Today I Errored - 1

const SpotifyWebApi = require('../'); const authorizationCode = '';/ const spotifyApi = new SpotifyWebApi({ clientId: '', clientSecret: '', redire

2022년 3월 3일
·
0개의 댓글

[err] Consider defining a bean of type 'org.springframework.stereotype.Repository' in your configuration.

코드를 돌리니 위와 같은 에러가 발생했다. 에러 코드를 좀 더 살펴보니 아래와 같은 에러 내용이 있었다.즉, controller에서 annotation관련한 에러가 있었다. controller에서 필요한 annotation은 아래와 같다.@RestController@A

2022년 2월 17일
·
0개의 댓글

node-sass npm ERR! command failed 오류 해결하기

깃 클론작업을 하던 중npm ci를 눌렀을 뿐인데 갑자기 설치중 오류가 났다node-sass npm ERR! command failed해당 오류는 sass 버전이 호환되지 않아서 일어나는 문제라고 하기에 node를 새로 설치하거나 그냥 node-sass 를 업데이트 해

2022년 1월 29일
·
0개의 댓글
post-thumbnail

[MongoDB] MongoParseError: options usecreateindex, usefindandmodify are not supported

다들 MongoDB를 사용할 때 연결을 도와주는 몽구스를 사용 할 것이다. 이런 식으로 연결을 할 것이다. 이때 만약 몽구스 버전이 6.0이상이라면 MongoParseError: options usecreateindex, usefindandmodify are not s

2021년 8월 30일
·
0개의 댓글