[백준 브론즈 V] 10952번: A+B - 5

DONI·2021년 8월 8일
0

Baekjoon Online Judge

목록 보기
28/31
post-thumbnail

문제

두 정수 A와 B를 입력받은 다음, A+B를 출력하는 프로그램을 작성하시오.


입력

입력은 여러 개의 테스트 케이스로 이루어져 있다.

각 테스트 케이스는 한 줄로 이루어져 있으며, 각 줄에 A와 B가 주어진다. (0 < A, B < 10)

입력의 마지막에는 0 두 개가 들어온다.


출력

각 테스트 케이스마다 A+B를 출력한다.


예제 입력 1

1 1
2 3
3 4
9 8
5 2
0 0

예제 출력 1

2
5
7
17
7


소스코드

  • Java 첫 번째 방법 : while 문
import java.util.*;
public class Main {
	public static void main(String[] args) {
		Scanner sc = new Scanner(System.in);
		while (true) {
			int a = sc.nextInt();
			int b = sc.nextInt();
			if (a == 0 && b == 0) break;
			System.out.println(a + b);
		} sc.close();
	}
}
  • Java 두 번째 방법 : do while 문
import java.util.*;
public class Main {
	public static void main(String[] args) {
		Scanner sc = new Scanner(System.in);
		do {
			int a = sc.nextInt();
			int b = sc.nextInt();
			if (a == 0 && b == 0) break;
			System.out.println(a + b);
		} while (true);
		sc.close();
	}
}

[바로가기] 10952번: A+B - 5

profile
틀린 내용이 있다면 댓글 또는 이메일로 알려주세요 ❤ꔛ❜

0개의 댓글