[Baekjoon] 18258 - 큐2

Chobby·2023년 11월 16일
1

Baekjoon

목록 보기
82/108

😀문제

정수를 저장하는 큐를 구현한 다음, 입력으로 주어지는 명령을 처리하는 프로그램을 작성하시오.

명령은 총 여섯 가지이다.

push X: 정수 X를 큐에 넣는 연산이다.
pop: 큐에서 가장 앞에 있는 정수를 빼고, 그 수를 출력한다. 만약 큐에 들어있는 정수가 없는 경우에는 -1을 출력한다.
size: 큐에 들어있는 정수의 개수를 출력한다.
empty: 큐가 비어있으면 1, 아니면 0을 출력한다.
front: 큐의 가장 앞에 있는 정수를 출력한다. 만약 큐에 들어있는 정수가 없는 경우에는 -1을 출력한다.
back: 큐의 가장 뒤에 있는 정수를 출력한다. 만약 큐에 들어있는 정수가 없는 경우에는 -1을 출력한다.


😁입력

첫째 줄에 주어지는 명령의 수 N (1 ≤ N ≤ 2,000,000)이 주어진다. 둘째 줄부터 N개의 줄에는 명령이 하나씩 주어진다. 주어지는 정수는 1보다 크거나 같고, 100,000보다 작거나 같다. 문제에 나와있지 않은 명령이 주어지는 경우는 없다.


😂출력

출력해야하는 명령이 주어질 때마다, 한 줄에 하나씩 출력한다.


🤣예제

예제 입력 1 
15
push 1
push 2
front
back
size
empty
pop
pop
pop
size
empty
pop
push 3
empty
front
예제 출력 1 
1
2
2
0
1
2
-1
0
1
-1
0
3

😃출처

  • 문제를 만든 사람: jh05013

😄알고리즘 분류

  • 자료 구조

😅시간 제한

  • Python 3: 3 초
  • PyPy3: 3 초
  • Python 2: 3 초
  • PyPy2: 3 초

😎나의풀이

shift() 사용 시 시간초과, 2중 스택 사용 시 시간초과... 답이 없어 Queue를 구현할 수 밖에 없다.

class Node {
    next = undefined
    prev = undefined
    constructor(value) {
        this.value = value
    }
}

class Queue {
    head = undefined
    tail = undefined
    size = 0

    enqueue(value) {
        const curNode = new Node(value)
        if(!this.head) this.head = curNode
        if(this.tail) {
            this.tail.next = curNode
            curNode.prev = this.tail
        }
        this.tail = curNode
        this.size += 1
    }

    dequeue() {
        if(!this.size) return -1
        const value = this.head.value
        this.head = this.head.next
        this.size -= 1
        return value
    }

    empty() {
        return !this.size ? 1 : 0
    }

    front() {
        return this.size ? this.head.value : -1
    }

    back() {
        return this.size ? this.tail.value : -1
    }
}

const input = require('fs').readFileSync('/dev/stdin').toString().trim().split("\n")
const queue = new Queue()
const result = []
input.shift()
input.forEach(a => {
    if(a.startsWith('push')) {
        const [_, val] = a.split(" ")
        queue.enqueue(Number(val))
    } 
    else if(a === 'pop') result.push(queue.dequeue())         
    else if(a === 'size') result.push(queue.size)
    else if(a === 'empty') result.push(queue.empty())
    else if(a === 'front') result.push(queue.front())
    else if(a === 'back') result.push(queue.back())
})

console.log(result.join("\n"))
profile
내 지식을 공유할 수 있는 대담함

0개의 댓글