ReactNative 0.63.4 version iOS build Fail

jjbrother·2021년 12월 29일
0

Reactnative

목록 보기
2/5

시작하며

현재 Reactnative의 버전이 0.66인데, 주어진 소스코드 분석을 위해서 0.63.4를 테스트 해볼려고 설치를 하고 iOS빌드를 했느데, code 65라고 뜨면서 무지막지만 스크롤을 보게 되었다. 에러는 아래와 같이 나왔다.

error Failed to build iOS project. We ran "xcodebuild" command but it exited with error code 65. To debug build logs further, consider building your app with Xcode.app, by opening React063Test.xcworkspace. Run CLI with --verbose flag for more details.

신기하게도 Android build는 잘 되었다. 구글 검색해서 Stackoverflow에 있는 내용 중 성공한 것을 정리한다. 좌표는 링크텍스트

특정 버전 ReactNative 설치 & iOS build

React Native CLI에서 특정 버전 설치는 아래와 같이 하면 된다. 공식문서에서 가져왔다.

npx react-native init AwesomeProject --version X.XX.X

설치후 ios build는
npx react-native run-ios
하면된다. 이 때, 엄청난 에러를 맞이 함.

Solution

Stackoverflow 링크에 있는 댓글 중 성공했던 것은, ios/Podfile을 일부를 주석처리 하는 것이었다. Podfile을 열어 아래에 있는 부분을 찾고, use_flipper! 부터 end까지 주석 처리 하면된다.

# Enables Flipper.
  #
  # Note that if you have use_frameworks! enabled, Flipper will not work and
  # you should disable these next few lines.
  use_flipper!
  post_install do |installer|
    flipper_post_install(installer)
  end

주석처리한 것은 다음과 같다.

Note 부분을 보면 use_frameworks!가 enable이면 delete하라고 나와 있다.

그 다음 아래를 실행하면 된다.
1. cd ios
2. delete Pods folder and Podfile.lock
3. pod install
4. pod update
5. cd .. && npx react-native run-ios

시뮬레이터가 실행이 안되고 아래와 같은 error가 뜨면 시뮬레이터를 완전히 종료 한 후 다시 빌드 하면 된다.

error Failed to launch the app on simulator, An error was encountered processing the command (domain=com.apple.CoreSimulator.SimError, code=405):
Unable to lookup in current state: Shutdown

profile
I'm working on GM TCK(old, GM Korea). I'm just starting Mobile App Development. Previously I've worked at various Vehicle Development Area

0개의 댓글