jQuery 3.5.0 이상 버전 사용 시 겪게 되는 self-closing tag 이슈

지니씨·2021년 8월 9일
0

프론트엔드

목록 보기
4/87

jquery 3.5.0 미만 버전에서는 다음과 같은 보안 취약점이 있다.
https://nvd.nist.gov/vuln/detail/CVE-2020-11023

현 기준 jQuery의 최신 버전은 3.6.0 이다.

jQuery를 3.5.0 이상 버전으로 업데이트 하면 노말태그에서 자식이 없는 경우 셀프클로징 태그를 사용한 부분이 중첩으로 돔이 형성된다.

self-closing tag 에 대해 논의가 이루어진 stackoverflow 질문이다
: https://stackoverflow.com/questions/3558119/are-non-void-self-closing-tags-valid-in-html5

mCustomScrollbar 오픈소스 라이브러리에서 normal element에 self-closing tag를 사용한 케이스를 발견하였고, 이를 수정하여 pr을 보낸 상태이다 : https://github.com/malihu/malihu-custom-scrollbar-plugin/pull/666

profile
하루 모아 평생 🧚🏻

0개의 댓글