백준 - 영역 구하기[Java]

스브코·2022년 3월 8일
0

dfs/bfs/recursion

목록 보기
1/16

문제 출처: https://www.acmicpc.net/problem/2583


문제 설명

눈금의 간격이 1인 M×N(M,N≤100)크기의 모눈종이가 있다. 이 모눈종이 위에 눈금에 맞추어 K개의 직사각형을 그릴 때, 이들 K개의 직사각형의 내부를 제외한 나머지 부분이 몇 개의 분리된 영역으로 나누어진다.

예를 들어 M=5, N=7 인 모눈종이 위에 <그림 1>과 같이 직사각형 3개를 그렸다면, 그 나머지 영역은 <그림 2>와 같이 3개의 분리된 영역으로 나누어지게 된다.

<그림 2>와 같이 분리된 세 영역의 넓이는 각각 1, 7, 13이 된다.

M, N과 K 그리고 K개의 직사각형의 좌표가 주어질 때, K개의 직사각형 내부를 제외한 나머지 부분이 몇 개의 분리된 영역으로 나누어지는지, 그리고 분리된 각 영역의 넓이가 얼마인지를 구하여 이를 출력하는 프로그램을 작성하시오.


입력

첫째 줄에 M과 N, 그리고 K가 빈칸을 사이에 두고 차례로 주어진다. M, N, K는 모두 100 이하의 자연수이다. 둘째 줄부터 K개의 줄에는 한 줄에 하나씩 직사각형의 왼쪽 아래 꼭짓점의 x, y좌표값과 오른쪽 위 꼭짓점의 x, y좌표값이 빈칸을 사이에 두고 차례로 주어진다. 모눈종이의 왼쪽 아래 꼭짓점의 좌표는 (0,0)이고, 오른쪽 위 꼭짓점의 좌표는(N,M)이다. 입력되는 K개의 직사각형들이 모눈종이 전체를 채우는 경우는 없다.

출력

첫째 줄에 분리되어 나누어지는 영역의 개수를 출력한다. 둘째 줄에는 각 영역의 넓이를 오름차순으로 정렬하여 빈칸을 사이에 두고 출력한다.


예제 입력

5 7 3
0 2 4 4
1 1 2 5
4 0 6 2

예제 출력

3
1 7 13

문제 풀이

import java.io.*;
import java.util.Arrays;
import java.util.Collections;
import java.util.LinkedList;

class Main {

    public static int count;

    public static void main(String[] args) throws IOException {
        BufferedReader br = new BufferedReader(new InputStreamReader(System.in));

        int[] input = Arrays.stream(br.readLine().split(" "))
                .mapToInt(Integer::parseInt)
                .toArray();
        int height = input[0];
        int width = input[1];
        int[][] board = new int[height][width];

        while(input[2] --> 0) {
            int[] input2 = Arrays.stream(br.readLine().split(" "))
                    .mapToInt(Integer::parseInt)
                    .toArray();
            for(int i = input2[1]; i < input2[3]; i++) {
                for(int j = input2[0]; j < input2[2]; j++) {
                    board[i][j] = 1;
                }
            }
        }
        //System.out.println(Arrays.deepToString(board));

        int[][] visited = Arrays.stream(board)
                .map(int[]::clone)
                .toArray(int[][]::new);
        LinkedList<Integer> areas = new LinkedList<>();
        int[] directionsX = {-1,0,1,0};
        int[] directionsY = {0,-1,0,1};

        for(int r = 0; r < board.length; r++) {
            for(int c = 0; c < board[0].length; c++) {
                count = 0;
                if(visited[r][c] == 0) {
                    dfs(board, visited, r, c, directionsX, directionsY);
                    areas.add(count);
                }
            }
        }

        Collections.sort(areas);
        System.out.println(areas.size());
        StringBuilder sb = new StringBuilder();
        for(int ans : areas)
            sb.append(ans).append(" ");
        System.out.println(sb);
        br.close();
    }

    public static void dfs(int[][] board, int[][] visited, int x, int y,
                           int[] directionsX, int[] directionsY) {

        visited[x][y] = 1;
        count++;

        for(int i = 0; i < directionsX.length; i++) {
            int nextX = x + directionsX[i];
            int nextY = y + directionsY[i];

            if(nextX >= 0 && nextY >= 0 && nextY < board[0].length && nextX < board.length) {
                if(visited[nextX][nextY] == 0)
                    dfs(board, visited, nextX, nextY, directionsX, directionsY);
            }
        }
    }
}

문제 풀이 순서

  1. 입력값을 받아서 2D array생성 후 좌표별로 표시를 한다. (1로 표시)

  2. 같은 2D array를 tracker용으로 카피한다.

  3. x, y 좌표로 상하 좌우로 스캔할 수 있게 direction array를 생성 후 dfs로 스캔한다.

  4. dfs로 스캔하면서 넓이들을 리스트에 저장 후 정렬하여 반환한다.

profile
익히는 속도가 까먹는 속도를 추월하는 그날까지...

0개의 댓글