[ERR] JVM is not suitable for this product.

armton·2022년 4월 6일
0

에러/오류

목록 보기
2/6

개발환경

OS: Windows 10
IDE: eclipse 2022-03
JAVA: 17


상황

  • 이클립스 새로 설치함(기존버전: 2019-03)
  • Java도 버전 17로 새로 설치함
  • 새 이클립스 실행하니까 아래와 같은 메시지와 함께 실행을 거부함

Version 1.8.0_211 of the JVM is not suitable for this product. version: 11 or greater is required.


해결

이클립스가 설치된 폴더의 eclipse.ini에서

Dosgi.requiredJavaVersion 값을 1.8로 변경

값을 17로 지정해봤는데 여전히 같은 오류가 나서 기존에 사용하던 1.8로 지정함.

.
.
.
.
.

그랬더니

An error has occurred. See the log file [경로]

뭐 이런 오류 메시지가 또 뜸.

이클립스는 JAVA로 만들어졌는데
이클립스르 실행시켜주는 가상머신을 못 찾아서 생긴 오류.

또 다시 eclipse.ini를 열고

vm 경로 지정해주기.

-vm
C:/Program Files/Java/jdk-17.0.2/bin/javaw.exe

개인마다 JDK 경로는 다를 수 있으니 꼭 확인해서!
javaw.exe가 자바를 실행시키는 가상머신임.

이제 실행 잘 된당


참고

profile
armton garnet

0개의 댓글